Toolio dashboard loading
Incident Report for Toolio
Resolved
It looks like there was a temporary glitch. We're continuing to investigate to understand what happened.
Posted Apr 04, 2023 - 18:35 UTC
Investigating
We are investigating the cause. Apologies for the inconvenience and we'll be updating this shortly.
Posted Apr 04, 2023 - 18:32 UTC
This incident affected: Toolio Dashboard.